World of Warcraft > Add-ons / Mods / Macros

Windows Vista Lag Fix

(1/2) > >>

Shadowwolf:
Its no secret I hate Windows Vista. I dont think Microsoft has ever made a larger piece of garbage software than Vista since its been a company, except for maybe Windows Millennium (ME).

Since switching to Vista, ive had a lot of "lag" and my latency numbers have just been higher then they were when I played the game with Windows XP.

For the longest time I thought perhaps it was Comcast (Comcrap), however while they are to blame for a lot of things, the constant high latency numbers (300-400) were partly Vista Ive now come to realize as well.

Vista uses a new technology known as "Receive Window Auto Tuning", and quite frankly, its complete crap. Basically the summary of it is it tries to adjust the receive window size of your TCP packets based on information it gathers from your network and your traffic habits. Well...this doesnt work well with applications like WoW which exchange a lot of data over the net.

The good news is I have found a way to disable this piece of trash feature and since doing so, my latency numbers have dropped back down to 100-200 range where they were back when I played using Windows XP.

Some might ask what prompted me to delve into finding a solution let alone blame Vista for my woes, and I will say that having a laptop using Windows XP with WoW on the exact same network getting latency numbers 100-200 and being connected with my desktop using Vista getting latency numbers of 300-400, I quickly realized its not the ISP's fault and is definitely something with the operating systems.

The fix for this can be done by anyone, though with Vista's stupid administration confirmation settings (see video below), you need to take a few steps to turn it off.

//www.youtube.com/watch?v=80sWifG40B0
Anyhow...

Open the Start Menu > Programs > Accessories > and right-click on "Command Prompt" and select "Run as Administrator"

 [ Invalid Attachment ]

At the prompt, type in the following exactly:


--- Code: ---netsh interface tcp set global autotuninglevel=disabled
--- End code ---

You should see "OK" returned on the next line when you hit enter. You can now close the Command prompt windows and should restart Windows to make sure it takes full effect.

If at any time you have problems and need to turn the feature back on, you can do so by typing the following at the same command prompt:


--- Code: ---netsh interface tcp set global autotuninglevel=normal
--- End code ---

If you want to look at the current status of the setting, use the following command:


--- Code: ---netsh interface tcp show global
--- End code ---

Windows Vista Lag Fix

Hopefully this will show you some improvements with your latency, it did for me so I would imagine it would do the same for others. Like anything though, results will vary based on a lot of things like your ISP, network speeds, computer speed, etc.

Kothnok:
Interesting...

I run Vista64, Charter is my ISP and I usually see my latency at the 60-180 latency level.  I wonder if that auto-tune thing has issues with different routers/ISPs.

Fab:
Hey,

Thanks Shadow. I run on vista too atm, and my latency is usually always over 200. I just disabled the function, and I'll see if there is a difference some time tonight

Thanks :)

Arcdelad:
any idea why this is happeneing shadow?

(see attached)

JohnnieRat:
you have to run the C thingy as an admin... i had that prob too

AMG JR fix compooters!

Navigation

[0] Message Index

[#] Next page

Go to full version